net-proxy/dnsproxy: remove old version
[gentoo.git] / net-ftp / yafc / yafc-1.3.7.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit bash-completion-r1 eutils
8
9 DESCRIPTION="Console ftp client with a lot of nifty features"
10 HOMEPAGE="http://www.yafc-ftp.com/"
11 SRC_URI="http://www.yafc-ftp.com/downloads/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
16 IUSE="ipv6 readline kerberos socks5 ssh"
17
18 DEPEND="dev-libs/openssl:0
19         sys-libs/ncurses:*
20         dev-libs/libbsd
21         readline? ( >=sys-libs/readline-6 )
22         kerberos? ( virtual/krb5 )
23         socks5? ( net-proxy/dante )
24         ssh? ( net-libs/libssh )"
25 RDEPEND="${DEPEND}"
26
27 DOCS=( BUGS NEWS README.md THANKS TODO )
28
29 src_prepare() {
30         epatch_user
31 }
32
33 src_configure() {
34         export ac_cv_ipv6=$(usex ipv6)
35         econf \
36                 $(use_with readline readline /usr) \
37                 $(use_with socks5 socks /usr) \
38                 $(use_with socks5 socks5 /usr) \
39                 $(use_with kerberos krb5) \
40                 $(use_with ssh) \
41                 --with-bash-completion="$(get_bashcompdir)"
42 }
43
44 src_install() {
45         default
46         dodoc -r samples
47 }