net-fs/netatalk-3.1.2: fix compilation due to my_bool, bug #692560
[gentoo.git] / net-fs / davfs2 / davfs2-1.5.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
7 HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
8 SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
9
10 LICENSE="GPL-3+"
11 SLOT="0"
12 KEYWORDS="~amd64 ~arm ~ppc ~x86"
13 IUSE="nls"
14 RESTRICT="test"
15
16 RDEPEND="dev-libs/libxml2
17         net-libs/neon
18         sys-libs/zlib
19         nls? ( virtual/libintl virtual/libiconv )
20 "
21 DEPEND="${REPEND}
22         nls? ( sys-devel/gettext )
23 "
24 RDEPEND="${RDEPEND}
25         acct-group/davfs2
26         acct-user/davfs2
27 "
28
29 src_prepare() {
30         # Let the package manager handle man page compression
31         sed -e '/^manual[58]_DATA/ s/\.gz//g' \
32                 -i "${S}"/man/Makefile.in || die
33
34         eapply "${FILESDIR}"/${PN}-1.5.5-gcc-10.patch
35
36         default
37 }
38
39 src_configure() {
40         econf --enable-largefile $(use_enable nls)
41 }
42
43 pkg_postinst() {
44         elog
45         elog "Quick setup:"
46         elog "   (as root)"
47         elog "   # gpasswd -a \${your_user} davfs2"
48         elog "   # echo 'https://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto  0  0' >> /etc/fstab"
49         elog "   (as user)"
50         elog "   \$ mkdir -p ~/dav"
51         elog "   \$ mount ~/dav"
52         elog
53 }