dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-fs / curlftpfs / curlftpfs-0.9.2-r4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="File system for accessing ftp hosts based on FUSE"
9 HOMEPAGE="http://curlftpfs.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux ~x86-macos"
15 IUSE=""
16 RESTRICT="test" # bug 258460
17
18 RDEPEND=">=net-misc/curl-7.17.0
19         >=sys-fs/fuse-2.2:0=
20         >=dev-libs/glib-2.0"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 PATCHES=(
25         "${FILESDIR}"/${P}-64bit_filesize.patch
26         "${FILESDIR}"/${PN}-0.9.2-darwin.patch
27         "${FILESDIR}"/${PN}-0.9.2-memleak.patch
28         "${FILESDIR}"/${PN}-0.9.2-memleak-nocache.patch
29         "${FILESDIR}"/${PN}-0.9.2-fix-escaping.patch
30         "${FILESDIR}"/${PN}-0.9.2-__off_t.patch
31 )
32
33 src_prepare() {
34         default
35
36         # automake-1.13.1 obsoletes AM_* bit #469818
37         sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
38
39         eautoreconf
40 }
41
42 src_install() {
43         default
44         dodoc README
45 }