Merge remote-tracking branch 'remotes/github/pr/52'.
[gentoo.git] / net-firewall / shapecfg / shapecfg-36.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit eutils flag-o-matic
6
7 DESCRIPTION="configuration tool for setting traffic bandwidth parameters"
8 HOMEPAGE="ftp://archive.download.redhat.com/pub/redhat/linux/9/en/os/i386/SRPMS http://sourceforge.net/projects/cbqinit"
9 SRC_URI="mirror://gentoo/shaper.${PV}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~x86"
14 IUSE=""
15
16 DEPEND=""
17
18 S=${WORKDIR}/shaper
19
20 src_unpack() {
21         unpack ${A}
22         cd "${S}"
23         epatch "${FILESDIR}"/shapercfg-2.0.36-glibc.patch
24         rm -f Makefile
25 }
26
27 src_compile() {
28         append-flags -Wall
29         emake shapecfg || die
30 }
31
32 src_install() {
33         dobin shapecfg || die
34         dodoc "${FILESDIR}"/README.shaper
35 }