net-firewall/iptables-1.6.1-r3: alpha stable, bug 641228
[gentoo.git] / net-firewall / shapecfg / shapecfg-36.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils flag-o-matic
7
8 DESCRIPTION="configuration tool for setting traffic bandwidth parameters"
9 HOMEPAGE="ftp://archive.download.redhat.com/pub/redhat/linux/9/en/os/i386/SRPMS https://sourceforge.net/projects/cbqinit"
10 SRC_URI="mirror://gentoo/shaper.${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~x86"
15 IUSE=""
16
17 DEPEND=""
18
19 S=${WORKDIR}/shaper
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}"/shapercfg-2.0.36-glibc.patch
25         rm -f Makefile
26 }
27
28 src_compile() {
29         append-flags -Wall
30         emake shapecfg || die
31 }
32
33 src_install() {
34         dobin shapecfg || die
35         dodoc "${FILESDIR}"/README.shaper
36 }