net-dns/odsclient: Fix docs installation (#656764)
[gentoo.git] / net-dns / odsclient / odsclient-1.03-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Client for the Open Domain Server's dynamic dns"
9 HOMEPAGE="http://www.ods.org/"
10 SRC_URI="http://www.ods.org/dl/${P}.tar.gz"
11 LICENSE="LGPL-2.1"
12
13 SLOT="0"
14 KEYWORDS="~amd64 x86"
15 IUSE=""
16
17 PATCHES=( "${FILESDIR}/${PV}-gentoo.patch" )
18
19 src_prepare() {
20         default
21         sed -i Makefile -e 's| -o | $(LDFLAGS)&|g' || die "sed failed"
22 }
23
24 src_compile() {
25         emake \
26                 CC=$(tc-getCC) \
27                 CFLAGS="${CFLAGS}" \
28                 LDFLAGS="${LDFLAGS}" \
29                 || die
30 }
31
32 src_install() {
33         dosbin odsclient
34         einstalldocs
35 }