dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-dns / https_dns_proxy / https_dns_proxy-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit git-r3 cmake-utils
6
7 DESCRIPTION="A lightweight DNS-over-HTTPS proxy."
8 HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
9 EGIT_REPO_URI="https://github.com/aarond10/${PN}.git"
10 SRC_URI=""
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE=""
16
17 DEPEND="dev-libs/libev
18         net-dns/c-ares
19         >=net-misc/curl-7.53.0[http2,ssl]
20         "
21 RDEPEND="${DEPEND}"
22
23 src_install() {
24         cmake-utils_src_install
25         exeinto /usr/bin
26         doexe "${S}_build/https_dns_proxy"
27 }