*/*: [QA] Remove redundant `|| die` guards
[gentoo.git] / net-dialup / xl2tpd / xl2tpd-1.3.12.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit systemd toolchain-funcs
7
8 DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
9 HOMEPAGE="https://github.com/xelerance/xl2tpd"
10 SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
15
16 DEPEND="
17         net-libs/libpcap
18         >=sys-kernel/linux-headers-2.6"
19
20 RDEPEND="
21         ${DEPEND}
22         net-dialup/ppp"
23
24 DOCS=(CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents)
25
26 src_compile() {
27         tc-export CC
28         emake OSFLAGS="-DLINUX"
29 }
30
31 src_install() {
32         emake PREFIX=/usr DESTDIR="${D}" install
33
34         newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
35
36         systemd_dounit "${FILESDIR}"/xl2tpd.service
37         systemd_dotmpfilesd "${FILESDIR}"/xl2tpd.conf
38
39         einstalldocs
40
41         insinto /etc/xl2tpd
42         newins doc/l2tpd.conf.sample xl2tpd.conf
43         insopts -m 0600
44         newins doc/l2tp-secrets.sample l2tp-secrets
45 }