net-dialup/ppp: arm64 stable (bug #710308)
[gentoo.git] / net-dialup / xc / xc-4.3.2-r3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils flag-o-matic multilib toolchain-funcs
7
8 DESCRIPTION="Modem dialout & serial terminal program"
9 HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
10 SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
11
12 LICENSE="xc-radley"
13 SLOT="0"
14 KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
15 IUSE=""
16
17 RDEPEND="sys-libs/ncurses"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-gentoo.patch
23         epatch "${FILESDIR}"/${P}-implicit-decl.patch
24         epatch "${FILESDIR}"/${P}-add-115200.patch
25
26         sed -i \
27                 -e "/^libdir/s:/lib/:/$(get_libdir)/:" \
28                 -e "/strip/d" \
29                 Makefile || die
30         # bug 459796
31         append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
32 }
33
34 src_compile() {
35         tc-export AR CC RANLIB
36         emake WARN="" all
37 }
38
39 src_install() {
40         default
41         insinto /usr/$(get_libdir)/xc
42         doins phonelist xc.init dotfiles/.[a-z]*
43 }