net-dialup/ppp: amd64/x86 stable wrt bug #710308
[gentoo.git] / net-dialup / sercd / sercd-3.0.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils
7
8 DESCRIPTION="RFC2217-compliant serial port redirector"
9 HOMEPAGE="https://sourceforge.net/projects/sercd"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 IUSE="xinetd"
17
18 RDEPEND="xinetd? ( virtual/inetd )"
19
20 DOCS=( AUTHORS README )
21
22 src_prepare() {
23         eapply_user
24 }
25
26 src_install() {
27         default
28
29         newinitd "${FILESDIR}/${PN}.initd" "${PN}"
30         newconfd "${FILESDIR}/${PN}.confd" "${PN}"
31         if use xinetd ; then
32                 insinto /etc/xinetd.d
33                 newins "${FILESDIR}/${PN}.xinetd" "${PN}"
34         fi
35 }