net-dialup/ppp-scripts: Add ~riscv keyword
[gentoo.git] / net-dialup / pptpclient / pptpclient-1.10.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 MY_P="${P/client}"
9 MY_CMD="pptp-command-20130515"
10
11 DESCRIPTION="Linux client for PPTP"
12 HOMEPAGE="http://pptpclient.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
14         https://dev.gentoo.org/~pinkbyte/distfiles/pptpclient/${MY_CMD}.bz2"
15
16 SLOT="0"
17 LICENSE="GPL-2"
18 KEYWORDS="alpha amd64 ~arm ~arm64 ppc ppc64 x86"
19 IUSE="tk"
20
21 DEPEND="net-dialup/ppp
22         dev-lang/perl
23         tk? ( dev-perl/Tk )"
24 RDEPEND="${DEPEND}
25         sys-apps/iproute2"
26
27 RESTRICT="test" #make test is useless and vector_test.c is broken
28
29 S="${WORKDIR}/${MY_P}"
30
31 DOCS=( AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING )
32
33 src_compile() {
34         emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
35 }
36
37 src_install() {
38         default
39         dodoc Documentation/*
40         dodir /etc/pptp.d
41
42         # The current version of pptp-linux doesn't include the
43         # RH-specific portions, so include them ourselves.
44         newsbin "${WORKDIR}/${MY_CMD}" pptp-command
45         dosbin "${FILESDIR}/pptp_fe.pl"
46         use tk && dosbin "${FILESDIR}/xpptp_fe.pl"
47 }