net-dialup/moserial: remove old
[gentoo.git] / net-dialup / ppp-scripts / ppp-scripts-0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Common set of scripts for various PPP implementations"
7 HOMEPAGE="https://gentoo.org/"
8 SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/${P}.tar.xz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~riscv ~s390 ~sh sparc x86"
13
14 DEPEND="!<net-dialup/ppp-2.4.7-r1"
15 RDEPEND="${DEPEND}"
16
17 S="${WORKDIR}"
18
19 src_install() {
20         exeinto /etc/ppp
21         for i in ip-up ip-down ; do
22                 doexe "scripts/${i}"
23                 insinto /etc/ppp/${i}.d
24                 dosym ${i} /etc/ppp/${i/ip/ipv6}
25                 doins "scripts/${i}.d"/*
26         done
27 }