net-dialup/ppp: arm stable, bug #546554
[gentoo.git] / net-dialup / ppp / ppp-2.4.5-r3.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit eutils multilib toolchain-funcs linux-info pam
8
9 PATCH_VER="3"
10 DESCRIPTION="Point-to-Point Protocol (PPP)"
11 HOMEPAGE="http://www.samba.org/ppp"
12 SRC_URI="ftp://ftp.samba.org/pub/ppp/${P}.tar.gz
13         https://dev.gentoo.org/~floppym/dist/${P}-patches-${PATCH_VER}.tar.xz
14         http://www.netservers.co.uk/gpl/ppp-dhcpc.tgz"
15
16 LICENSE="BSD GPL-2"
17 SLOT="0"
18 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
19 IUSE="activefilter atm dhcp eap-tls gtk ipv6 pam radius"
20
21 DEPEND="activefilter? ( net-libs/libpcap )
22         atm? ( net-dialup/linux-atm )
23         pam? ( virtual/pam )
24         gtk? ( x11-libs/gtk+:2 )
25         eap-tls? ( net-misc/curl dev-libs/openssl )"
26 RDEPEND="${DEPEND}"
27
28 src_prepare() {
29         # Use the headers from the kernel #427684
30         rm include/linux/if_pppol2tp.h || die
31
32         mv "${WORKDIR}/dhcp" "${S}/pppd/plugins" || die
33
34         use eap-tls || EPATCH_EXCLUDE+=" 8?_all_eaptls-*"
35         EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
36
37         if use atm ; then
38                 einfo "Enabling PPPoATM support"
39                 sed -i '/^#HAVE_LIBATM=yes/s:#::' pppd/plugins/pppoatm/Makefile.linux || die
40         fi
41
42         if ! use activefilter ; then
43                 einfo "Disabling active filter"
44                 sed -i '/^FILTER=y/s:^:#:' pppd/Makefile.linux || die
45         fi
46
47         if use pam ; then
48                 einfo "Enabling PAM"
49                 sed -i '/^#USE_PAM=y/s:^#::' pppd/Makefile.linux || die
50         fi
51
52         if use ipv6 ; then
53                 einfo "Enabling IPv6"
54                 sed -i '/#HAVE_INET6/s:#::' pppd/Makefile.linux || die
55         fi
56
57         einfo "Enabling CBCP"
58         sed -i '/^#CBCP=y/s:#::' pppd/Makefile.linux || die
59
60         if use dhcp ; then
61                 einfo "Adding ppp-dhcp plugin files"
62                 sed -i \
63                         -e '/^SUBDIRS :=/s:$: dhcp:' \
64                         pppd/plugins/Makefile.linux || die
65         fi
66
67         # Set correct libdir
68         sed -i -e "s:/lib/pppd:/$(get_libdir)/pppd:" \
69                 pppd/{pathnames.h,pppd.8}
70
71         if use radius ; then
72                 #set the right paths in radiusclient.conf
73                 sed -i -e "s:/usr/local/etc:/etc:" \
74                         -e "s:/usr/local/sbin:/usr/sbin:" pppd/plugins/radius/etc/radiusclient.conf
75                 #set config dir to /etc/ppp/radius
76                 sed -i -e "s:/etc/radiusclient:/etc/ppp/radius:g" \
77                         pppd/plugins/radius/{*.8,*.c,*.h} \
78                         pppd/plugins/radius/etc/*
79         else
80                 einfo "Disabling radius"
81                 sed -i -e '/+= radius/s:^:#:' pppd/plugins/Makefile.linux
82         fi
83 }
84
85 src_compile() {
86         tc-export AR CC
87         emake COPTS="${CFLAGS} -D_GNU_SOURCE"
88
89         # build pppgetpass
90         cd contrib/pppgetpass
91         if use gtk ; then
92                 emake -f Makefile.linux
93         else
94                 emake pppgetpass.vt
95         fi
96 }
97
98 src_install() {
99         local i
100         for i in chat pppd pppdump pppstats ; do
101                 doman ${i}/${i}.8
102                 dosbin ${i}/${i}
103         done
104         fperms u+s-w /usr/sbin/pppd
105
106         # Install pppd header files
107         emake -C pppd INSTROOT="${D}" install-devel
108
109         dosbin pppd/plugins/rp-pppoe/pppoe-discovery
110
111         dodir /etc/ppp/peers
112         insinto /etc/ppp
113         insopts -m0600
114         newins etc.ppp/pap-secrets pap-secrets.example
115         newins etc.ppp/chap-secrets chap-secrets.example
116
117         insopts -m0644
118         doins etc.ppp/options
119
120         exeinto /etc/ppp
121         for i in ip-up ip-down ; do
122                 doexe "${WORKDIR}/scripts/${i}"
123                 insinto /etc/ppp/${i}.d
124                 use ipv6 && dosym ${i} /etc/ppp/${i/ip/ipv6}
125                 doins "${WORKDIR}/scripts/${i}.d"/*
126         done
127
128         pamd_mimic_system ppp auth account session
129
130         local PLUGINS_DIR=/usr/$(get_libdir)/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
131         # closing " for syntax coloring
132         insinto "${PLUGINS_DIR}"
133         insopts -m0755
134         doins pppd/plugins/minconn.so
135         doins pppd/plugins/passprompt.so
136         doins pppd/plugins/passwordfd.so
137         doins pppd/plugins/winbind.so
138         doins pppd/plugins/rp-pppoe/rp-pppoe.so
139         doins pppd/plugins/pppol2tp/openl2tp.so
140         doins pppd/plugins/pppol2tp/pppol2tp.so
141         if use atm ; then
142                 doins pppd/plugins/pppoatm/pppoatm.so
143         fi
144         if use dhcp ; then
145                 doins pppd/plugins/dhcp/dhcpc.so
146         fi
147         if use radius ; then
148                 doins pppd/plugins/radius/rad{ius,attr,realms}.so
149
150                 #Copy radiusclient configuration files (#92878)
151                 insinto /etc/ppp/radius
152                 insopts -m0644
153                 doins pppd/plugins/radius/etc/{dictionary*,issue,port-id-map,radiusclient.conf,realms,servers}
154
155                 doman pppd/plugins/radius/pppd-rad{ius,attr}.8
156         fi
157
158         insinto /etc/modprobe.d
159         insopts -m0644
160         newins "${FILESDIR}/modules.ppp" ppp.conf
161
162         dodoc PLUGINS README* SETUP Changes-2.3 FAQ
163         dodoc "${FILESDIR}/README.mpls"
164
165         dosbin scripts/p{on,off,log}
166         doman scripts/pon.1
167
168         # Adding misc. specialized scripts to doc dir
169         insinto /usr/share/doc/${PF}/scripts/chatchat
170         doins scripts/chatchat/*
171         insinto /usr/share/doc/${PF}/scripts
172         doins scripts/*
173
174         if use gtk ; then
175                 dosbin contrib/pppgetpass/{pppgetpass.vt,pppgetpass.gtk}
176                 newsbin contrib/pppgetpass/pppgetpass.sh pppgetpass
177         else
178                 newsbin contrib/pppgetpass/pppgetpass.vt pppgetpass
179         fi
180         doman contrib/pppgetpass/pppgetpass.8
181 }
182
183 pkg_postinst() {
184         if linux-info_get_any_version && linux_config_src_exists ; then
185                 echo
186                 ewarn "If the following test report contains a missing kernel configuration option that you need,"
187                 ewarn "you should reconfigure and rebuild your kernel before running pppd."
188                 CONFIG_CHECK="~PPP ~PPP_ASYNC ~PPP_SYNC_TTY"
189                 local ERROR_PPP="CONFIG_PPP:\t missing PPP support (REQUIRED)"
190                 local ERROR_PPP_ASYNC="CONFIG_PPP_ASYNC:\t missing asynchronous serial line discipline (optional, but highly recommended)"
191                 local WARNING_PPP_SYNC_TTY="CONFIG_PPP_SYNC_TTY:\t missing synchronous serial line discipline (optional; used by 'sync' pppd option)"
192                 if use activefilter ; then
193                         CONFIG_CHECK="${CONFIG_CHECK} ~PPP_FILTER"
194                         local ERROR_PPP_FILTER="CONFIG_PPP_FILTER:\t missing PPP filtering support (REQUIRED)"
195                 fi
196                 CONFIG_CHECK="${CONFIG_CHECK} ~PPP_DEFLATE ~PPP_BSDCOMP ~PPP_MPPE"
197                 local ERROR_PPP_DEFLATE="CONFIG_PPP_DEFLATE:\t missing Deflate compression (optional, but highly recommended)"
198                 local ERROR_PPP_BSDCOMP="CONFIG_PPP_BSDCOMP:\t missing BSD-Compress compression (optional, but highly recommended)"
199                 local WARNING_PPP_MPPE="CONFIG_PPP_MPPE:\t missing MPPE encryption (optional, mostly used by PPTP links)"
200                 CONFIG_CHECK="${CONFIG_CHECK} ~PPPOE ~PACKET"
201                 local WARNING_PPPOE="CONFIG_PPPOE:\t missing PPPoE support (optional, needed by rp-pppoe plugin)"
202                 local WARNING_PACKET="CONFIG_PACKET:\t missing AF_PACKET support (optional, used by rp-pppoe and dhcpc plugins)"
203                 if use atm ; then
204                         CONFIG_CHECK="${CONFIG_CHECK} ~PPPOATM"
205                         local WARNING_PPPOATM="CONFIG_PPPOATM:\t missing PPPoA support (optional, needed by pppoatm plugin)"
206                 fi
207                 check_extra_config
208         fi
209
210         # create *-secrets files if not exists
211         [ -f "${ROOT}/etc/ppp/pap-secrets" ] || \
212                 cp -pP "${ROOT}/etc/ppp/pap-secrets.example" "${ROOT}/etc/ppp/pap-secrets"
213         [ -f "${ROOT}/etc/ppp/chap-secrets" ] || \
214                 cp -pP "${ROOT}/etc/ppp/chap-secrets.example" "${ROOT}/etc/ppp/chap-secrets"
215
216         # lib name has changed
217         sed -i -e "s:^pppoe.so:rp-pppoe.so:" "${ROOT}/etc/ppp/options"
218
219         echo
220         elog "Pon, poff and plog scripts have been supplied for experienced users."
221         elog "Users needing particular scripts (ssh,rsh,etc.) should check out the"
222         elog "/usr/share/doc/${PF}/scripts directory."
223 }