net-dialup/ppp: stable 2.4.8 for ia64, bug #710308
[gentoo.git] / net-dialup / mingetty / mingetty-1.08-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs eutils
7
8 DESCRIPTION="A compact getty program for virtual consoles only"
9 HOMEPAGE="https://sourceforge.net/projects/mingetty"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
15 IUSE="unicode"
16
17 PATCHES=(
18         "${FILESDIR}/${PN}-1.08-check_chroot_chdir_nice.patch"
19 )
20
21 src_prepare() {
22         use unicode && eapply "${FILESDIR}"/${PN}-1.08-utf8.patch
23         default
24 }
25
26 src_compile() {
27         emake CFLAGS="${CFLAGS} -Wall -W -pipe -D_GNU_SOURCE" CC="$(tc-getCC)"
28 }
29
30 src_install() {
31         dodir /sbin /usr/share/man/man8
32         emake DESTDIR="${D}" install
33 }