Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / net-dialup / linux-atm / linux-atm-2.5.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils flag-o-matic libtool linux-info
8
9 DESCRIPTION="Tools for ATM"
10 HOMEPAGE="http://linux-atm.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
16 IUSE="static-libs"
17
18 RDEPEND=""
19 DEPEND="virtual/yacc"
20
21 RESTRICT="test"
22
23 DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS )
24
25 CONFIG_CHECK="~ATM"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-headers.patch
29
30         sed -i '/#define _LINUX_NETDEVICE_H/d' \
31                 src/arpd/*.c || die "sed command on arpd/*.c files failed"
32
33         elibtoolize
34 }
35
36 src_configure() {
37         append-flags -fno-strict-aliasing
38
39         econf $(use_enable static-libs static)
40 }
41
42 src_install() {
43         default
44         prune_libtool_files
45         dodoc doc/README* doc/atm*
46 }