dev-perl/Exception-Class: amd64 stable wrt bug #657574
[gentoo.git] / net-dialup / linux-atm / linux-atm-2.5.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils libtool flag-o-matic toolchain-funcs
7
8 DESCRIPTION="Tools for ATM"
9 HOMEPAGE="http://linux-atm.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
15 IUSE=""
16
17 RDEPEND=""
18 DEPEND="virtual/yacc"
19
20 RESTRICT="test"
21
22 src_unpack() {
23         unpack ${A}
24
25         cd "${S}"
26         epatch "${FILESDIR}"/${P}-headers.patch
27         epatch "${FILESDIR}"/${P}-glibc28.patch
28         epatch "${FILESDIR}"/${P}-bison24.patch
29
30         sed -i '/#define _LINUX_NETDEVICE_H/d' \
31                 src/arpd/*.c || die "sed command on arpd/*.c files failed"
32         sed -i 's:cp hosts.atm /etc:cp hosts.atm ${DESTDIR}/etc:' \
33                 src/config/Makefile.in || die "sed command on Makefile.in failed"
34
35         elibtoolize
36 }
37
38 src_compile() {
39         append-flags -fno-strict-aliasing
40
41         CC_FOR_BUILD=$(tc-getCC) econf || die "econf failed"
42         emake || die "emake failed"
43 }
44
45 src_install() {
46         emake DESTDIR="${D}" install || die "make install failed"
47
48         dodoc README NEWS THANKS AUTHORS BUGS ChangeLog
49         dodoc doc/README* doc/atm*
50 }