c138c7f6d5820bee0316ab12b283a13bb9840ac8
[gentoo.git] / net-dialup / freeradius-client / freeradius-client-1.1.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit autotools-utils
7
8 DESCRIPTION="FreeRADIUS Client framework"
9 HOMEPAGE="http://wiki.freeradius.org/Radiusclient"
10 SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86"
15
16 IUSE="scp shadow static-libs"
17
18 DEPEND="!net-dialup/radiusclient
19         !net-dialup/radiusclient-ng"
20 RDEPEND="${DEPEND}"
21
22 DOCS=( BUGS doc/ChangeLog doc/login.example doc/release-method.txt )
23
24 src_configure() {
25         local myeconfargs=(
26                 $(use_enable scp)
27                 $(use_enable shadow)
28                 --with-secure-path
29         )
30         autotools-utils_src_configure
31 }
32
33 src_install() {
34         autotools-utils_src_install
35         dodoc README*
36         newdoc doc/README README.login.example
37         dohtml doc/instop.html
38 }