net-analyzer/fail2ban: amd64 stable wrt bug #719458
[gentoo.git] / net-analyzer / wapiti / wapiti-3.0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 PYTHON_REQ_USE='xml'
8
9 inherit distutils-r1
10
11 MY_P=${PN}3-${PV}
12 DESCRIPTION="Web-application vulnerability scanner"
13 HOMEPAGE="http://wapiti.sourceforge.net/"
14 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="kerberos ntlm"
20
21 RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
22         dev-python/lxml[${PYTHON_USEDEP}]
23         dev-python/mako[${PYTHON_USEDEP}]
24         >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
25         dev-python/tld[${PYTHON_USEDEP}]
26         dev-python/yaswfp[${PYTHON_USEDEP}]
27         kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
28         ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
29
30 S=${WORKDIR}/${MY_P}
31
32 python_prepare_all() {
33         sed -e 's/"pytest-runner"//' -i setup.py || die
34         distutils-r1_python_prepare_all
35 }