net-analyzer/zabbix: removed obsolete 4.0.18 and 4.4.6
[gentoo.git] / net-analyzer / trafshow / trafshow-5.2.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils
6
7 DESCRIPTION="Full screen visualization of the network traffic"
8 HOMEPAGE="http://soft.risp.ru/trafshow/index_en.shtml"
9 SRC_URI="ftp://ftp.nsk.su/pub/RinetSoftware/${P}.tgz"
10
11 LICENSE="BSD"
12 SLOT="3"
13 KEYWORDS="amd64 hppa ~ppc ppc64 sparc x86"
14 IUSE="slang"
15
16 DEPEND="
17         net-libs/libpcap
18         !slang? ( sys-libs/ncurses )
19         slang? ( >=sys-libs/slang-1.4 )
20 "
21
22 src_prepare() {
23         cat /usr/share/aclocal/pkg.m4 >> aclocal.m4 || die
24         epatch \
25                 "${FILESDIR}"/${P}-gcc44.patch \
26                 "${FILESDIR}"/${P}-gentoo.patch \
27                 "${FILESDIR}"/${P}-tinfo.patch
28         eautoreconf
29 }
30
31 src_configure() {
32         if ! use slang; then
33                 # No command-line option so pre-cache instead
34                 export ac_cv_have_curses=ncurses
35                 export LIBS=-lncurses
36         fi
37
38         econf
39 }