Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / net-analyzer / thcrut / thcrut-1.2.5-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools eutils
7
8 DESCRIPTION="Network discovery and fingerprinting tool"
9 HOMEPAGE="http://www.thc.org/thc-rut/"
10 SRC_URI="http://www.thc.org/thc-rut/${P}.tar.gz"
11
12 LICENSE="free-noncomm PCRE GPL-1+"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc sparc x86"
15
16 DEPEND="
17         dev-libs/libpcre
18         net-libs/libnet:1.0
19         net-libs/libpcap
20 "
21
22 src_prepare() {
23         rm -r Libnet-1.0.2a pcre-3.9 || die
24         epatch \
25                 "${FILESDIR}"/${P}-libnet.patch \
26                 "${FILESDIR}"/${P}-configure.patch
27         eautoreconf
28 }
29
30 DOCS=( ChangeLog FAQ README TODO thcrutlogo.txt )