Drop $Id$ per council decision in bug #611234.
[gentoo.git] / net-analyzer / ripe-atlas-tools / ripe-atlas-tools-1.2.3-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_4 )
7
8 inherit distutils-r1
9
10 MY_PN=${PN//-/.}
11 DESCRIPTION="The official command-line client for RIPE Atlas"
12 HOMEPAGE="https://atlas.ripe.net/"
13 SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.tools/ripe.atlas.tools-${PV}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19
20 S="${WORKDIR}/${MY_PN}-${PV}"
21
22 DOCS=( CHANGES.rst README.rst )
23
24 RDEPEND="
25         >=net-libs/ripe-atlas-sagan-1.1.10[${PYTHON_USEDEP}]
26         >=www-client/ripe-atlas-cousteau-1.2[${PYTHON_USEDEP}]
27         >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
28         >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
29         dev-python/pyyaml[${PYTHON_USEDEP}]
30         dev-python/tzlocal[${PYTHON_USEDEP}]
31         dev-python/python-dateutil[${PYTHON_USEDEP}]
32         dev-python/ujson[${PYTHON_USEDEP}]"
33 DEPEND="
34         dev-python/setuptools[${PYTHON_USEDEP}]
35         test? (
36                 ${RDEPEND}
37                 dev-python/nose[${PYTHON_USEDEP}]
38                 $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
39
40 python_test() {
41         nosetests --verbose || die "Tests failed with ${EPYTHON}"
42 }
43
44 python_install() {
45         distutils-r1_python_install
46         echo "RIPE Atlas Tools (Magellan) [Gentoo Linux] ${PVR}" > \
47                 ${D}$(python_get_sitedir)/ripe/atlas/tools/user-agent
48 }