net-analyzer/*: Update Manifest hashes
[gentoo.git] / net-analyzer / prelude-correlator / prelude-correlator-4.0.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
6
7 inherit distutils-r1 systemd
8
9 DESCRIPTION="Real time correlator of events received by Prelude Manager"
10 HOMEPAGE="https://www.prelude-siem.org"
11 SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18
19 RDEPEND="~dev-libs/libprelude-${PV}[python,${PYTHON_USEDEP}]
20         dev-python/netaddr[${PYTHON_USEDEP}]"
21
22 src_install() {
23         distutils-r1_src_install
24
25         systemd_dounit "${FILESDIR}/${PN}.service"
26         systemd_newtmpfilesd "${FILESDIR}/${PN}.run" "${PN}.conf"
27
28         newinitd "${FILESDIR}/${PN}.initd" "${PN}"
29 }