net-analyzer/zabbix: removed obsolete 4.0.18 and 4.4.6
[gentoo.git] / net-analyzer / portmon / portmon-2.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Portmon is a network service monitoring daemon"
7 HOMEPAGE="http://aboleo.net/software/portmon/"
8 SRC_URI="http://aboleo.net/software/portmon/downloads/${P}.tar.gz"
9
10 KEYWORDS="~amd64 ~ppc ~x86"
11 SLOT="0"
12 LICENSE="GPL-2"
13
14 PATCHES=(
15         "${FILESDIR}"/${P}-fno-common.patch
16 )
17
18 src_configure() {
19         econf --sysconfdir=/etc/portmon
20 }
21
22 src_install() {
23         into /usr
24         dosbin src/portmon
25
26         doman extras/portmon.8
27
28         insinto /etc/portmon
29         doins extras/portmon.hosts.sample
30         dodoc AUTHORS BUGS README
31
32         newinitd "${FILESDIR}"/portmon.init portmon
33 }