24f2cac6bb8d099a432509db6b768ccfaaf2b9bd
[gentoo.git] / net-analyzer / ospd / ospd-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
10 HOMEPAGE="https://www.greenbone.net/en/"
11 SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="extras"
17
18 RDEPEND="
19         dev-python/defusedxml[${PYTHON_USEDEP}]
20         dev-python/lxml[${PYTHON_USEDEP}]
21         dev-python/paramiko[${PYTHON_USEDEP}]"
22
23 DEPEND="
24         ${RDEPEND}"
25
26 python_compile() {
27         if use extras; then
28                 bash "${S}"/doc/generate || die
29                 HTML_DOCS=( "${S}"/doc/. )
30         fi
31         distutils-r1_python_compile
32 }