sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / net-analyzer / nload / nload-0.7.4-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="Real time network traffic monitor for the command line interface"
9 HOMEPAGE="http://www.roland-riegel.de/nload/index.html"
10 SRC_URI="http://www.roland-riegel.de/nload/${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
15
16 RDEPEND=">=sys-libs/ncurses-5.2:0="
17 DEPEND="${RDEPEND}"
18 BDEPEND="virtual/pkgconfig"
19
20 PATCHES=(
21         "${FILESDIR}"/${P}-tinfo.patch
22         "${FILESDIR}"/${P}-Eliminate-flicker-on-some-terminals.patch
23         "${FILESDIR}"/${P}-Makefile-spec-don-t-compress-man-page.patch
24 )
25
26 src_prepare() {
27         default
28         eautoreconf
29 }
30
31 src_configure() {
32         # --enable-debug means do not strip debugging symbols (default no)
33         econf --enable-debug
34 }