dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / net-analyzer / netio / netio-1.32-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="measures net throughput with NetBIOS and TCP/IP protocols"
8 HOMEPAGE="https://web.ars.de/netio/"
9 SRC_URI="http://web.ars.de/wp-content/uploads/2017/04/${PN}${PV/./}.zip"
10
11 LICENSE="free-noncomm"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
14 RESTRICT="mirror" # bug #391789 comment #1
15
16 DEPEND="
17         app-arch/unzip
18         >=sys-apps/sed-4
19 "
20
21 S="${WORKDIR}"
22 PATCHES=(
23         "${FILESDIR}"/${PN}-1.26-linux-include.patch
24 )
25
26 src_prepare() {
27         edos2unix *.c *.h *.doc
28
29         default
30
31         sed -i \
32                 -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
33                 -e 's|\(CC\)=|\1?=|g' \
34                 -e 's|\(CFLAGS\)=|\1+=|g' \
35                 Makefile || die
36 }
37
38 src_compile() {
39         emake \
40                 CC="$(tc-getCC)" \
41                 CFLAGS="${CFLAGS}" \
42                 linux
43 }
44
45 src_install() {
46         dobin netio
47         dodoc netio.doc
48 }