media-fonts/noto: ppc64 stable wrt bug #691514
[gentoo.git] / net-analyzer / nagios-sap-ccms-plugin / nagios-sap-ccms-plugin-0.7.3-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit multilib
7
8 MY_P="sap-ccms-plugin-${PV}"
9
10 DESCRIPTION="Nagios plugin that provides an interface to SAP CCMS
11 Infrastructure"
12 HOMEPAGE="https://sourceforge.net/projects/nagios-sap-ccms/"
13 SRC_URI="mirror://sourceforge/nagios-sap-ccms/${MY_P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="x86"
18 IUSE=""
19
20 DEPEND="net-analyzer/nagios-core"
21 RDEPEND=${DEPEND}
22
23 S=${WORKDIR}/${MY_P}
24
25 src_compile() {
26         cd "${S}/src"
27         emake || die "emake failed"
28 }
29
30 src_install() {
31         cd "${S}/src"
32         exeinto /usr/$(get_libdir)/nagios/plugins
33
34         for file in {check_sap{,_cons,_instance,_instance_cons,_mult_no_thr,_multiple,_system,_system_cons},create_cfg,sap_change_thr}
35         do
36                 doexe ${file}
37         done
38
39         chown -R root:nagios "${D}"/usr/$(get_libdir)/nagios/plugins || die "Failed Chown of ${D}usr/$(get_libdir)/nagios/plugins"
40
41         dolib.so sap_moni.so
42         cd "${S}/config"
43
44         dodir /etc/sapmon
45         insinto /etc/sapmon
46         doins "${S}"/config/*
47 }
48
49 pkg_postinst() {
50         elog "Have a look at /etc/sapmon for configuring ${PN}"
51         elog "Further information can be found at"
52         elog "http://nagios-sap-ccms.sourceforge.net/"
53 }