dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-analyzer / nagios-check_mysql_health / nagios-check_mysql_health-2.2.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN#nagios-}"
7 MY_P="${MY_PN}-${PV}"
8
9 DESCRIPTION="A nagios plugin for checking MySQL server health"
10 HOMEPAGE="https://labs.consol.de/nagios/check_mysql_health/"
11 SRC_URI="https://labs.consol.de/assets/downloads/nagios/${MY_P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 # Found by grepping for "use " in the built
19 # plugins-scripts/check_mysql_health.
20 RDEPEND="dev-perl/DBD-mysql
21         dev-perl/DBI
22         virtual/perl-Data-Dumper
23         virtual/perl-File-Temp
24         virtual/perl-Net-Ping
25         virtual/perl-Time-HiRes"
26
27 S="${WORKDIR}/${MY_P}"
28
29 src_configure() {
30         # Should match net-analyzer/{monitoring,nagios}-plugins.
31         econf --libexecdir="/usr/$(get_libdir)/nagios/plugins"
32 }
33
34 # Here we should have a pkg_preinst() that creates the nagios user/group
35 # (using the same command from e.g. net-analyzer/nagios-plugins). But
36 # right now, the build system for check_mysql_health has a bug: it
37 # doesn't use the configured user (INSTALL_OPTIONS aren't passed to
38 # /usr/bin/install), so it's pointless. Don't forget to inherit
39 # user.eclass!