Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / net-analyzer / lilac / lilac-1.0.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils webapp
8
9 DESCRIPTION="Web-based configuration tool written to configure Nagios"
10 HOMEPAGE="http://www.lilacplatform.com"
11 SRC_URI="mirror://gentoo/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="
17         >=dev-php/PEAR-PEAR-1.6.1
18         >=net-analyzer/nagios-3.0
19         >=virtual/mysql-5.0
20         dev-lang/php[curl,json,mysql,pcntl,pdo,posix,simplexml]
21         virtual/httpd-php
22 "
23
24 src_install() {
25         webapp_src_preinst
26
27         dodoc INSTALL UPGRADING
28         rm -f INSTALL UPGRADING
29
30         insinto "${MY_HTDOCSDIR}"
31         doins -r .
32
33         webapp_configfile "${MY_HTDOCSDIR}"/includes/lilac-conf.php.dist
34         webapp_serverowned "${MY_HTDOCSDIR}"/includes/lilac-conf.php.dist
35         webapp_src_install
36 }