dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / net-analyzer / ike-scan / ike-scan-1.9.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
8 HOMEPAGE="https://github.com/royhills/ike-scan/"
9 SRC_URI="https://github.com/royhills/ike-scan/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE="libressl ssl"
15
16 DEPEND="
17         ssl? (
18                 !libressl? ( dev-libs/openssl:0= )
19                 libressl? ( dev-libs/libressl:0= )
20         )
21 "
22 RDEPEND="
23         ${DEPEND}
24 "
25
26 src_prepare() {
27         # Fix buffer overflow, bug #277556
28         sed \
29                 -e "/MAXLINE/s:255:511:g" \
30                 -i ike-scan.h || die
31
32         default
33
34         eautoreconf
35 }
36
37 src_configure() {
38         econf $(use_with ssl openssl)
39 }
40
41 src_install() {
42         default
43         dodoc udp-backoff-fingerprinting-paper.txt
44 }