dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / net-analyzer / ike-scan / ike-scan-1.9-r2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
7 HOMEPAGE="http://www.nta-monitor.com/ike-scan/"
8 SRC_URI="http://www.nta-monitor.com/ike-scan/download/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc x86"
13 IUSE="libressl ssl"
14
15 DEPEND="ssl? (
16         !libressl? ( dev-libs/openssl:0= )
17         libressl? ( dev-libs/libressl:0= )
18 )"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         # Fix buffer overflow, bug #277556
23         sed \
24                 -e "/MAXLINE/s:255:511:g" \
25                 -i ike-scan.h || die
26 }
27
28 src_configure() {
29         # --disable-lookup prevents ike-scan from phoning home
30         # for more information, please see bug 157507
31         econf $(use_with ssl openssl) --disable-lookup
32 }
33
34 src_install() {
35         default
36         dodoc udp-backoff-fingerprinting-paper.txt
37 }