sys-libs/ncurses: move to SLOT=0 #557472
[gentoo.git] / net-analyzer / iftop / iftop-1.0_pre4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils
8
9 DESCRIPTION="display bandwidth usage on an interface"
10 SRC_URI="http://www.ex-parrot.com/pdw/iftop/download/${P/_/}.tar.gz"
11 HOMEPAGE="http://www.ex-parrot.com/pdw/iftop/"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
16 IUSE=""
17
18 RDEPEND="
19         net-libs/libpcap
20         sys-libs/ncurses:0="
21 DEPEND="
22         ${RDEPEND}
23         virtual/pkgconfig
24 "
25
26 S="${WORKDIR}"/${P/_/}
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-tinfo.patch
30
31         # bug 490168
32         cat "${FILESDIR}"/ax_pthread.m4 >> "${S}"/acinclude.m4 || die
33         epatch "${FILESDIR}"/${P}-pthread.patch
34
35         eautoreconf
36 }
37
38 src_install() {
39         dosbin iftop
40         doman iftop.8
41
42         dodoc AUTHORS ChangeLog README "${FILESDIR}"/iftoprc
43 }