aeb8c0813eb720315253551a7f9cbae773dff120
[gentoo.git] / net-analyzer / iftop / iftop-1.0_pre4-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils
7
8 DESCRIPTION="display bandwidth usage on an interface"
9 SRC_URI="http://www.ex-parrot.com/pdw/iftop/download/${P/_/}.tar.gz"
10 HOMEPAGE="http://www.ex-parrot.com/pdw/iftop/"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm hppa ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
15 IUSE=""
16
17 RDEPEND="
18         net-libs/libpcap
19         sys-libs/ncurses:0=
20 "
21 DEPEND="
22         ${RDEPEND}
23         virtual/pkgconfig
24 "
25
26 S="${WORKDIR}"/${P/_/}
27
28 src_prepare() {
29         epatch \
30                 "${FILESDIR}"/${P}-configure.ac.patch \
31                 "${FILESDIR}"/${P}-Makefile.am.patch \
32                 "${FILESDIR}"/${P}-tsent-set-but-not-used.patch
33
34         # bug 490168
35         cat "${FILESDIR}"/ax_pthread.m4 >> "${S}"/acinclude.m4 || die
36
37         eautoreconf
38 }
39
40 src_install() {
41         dosbin iftop
42         doman iftop.8
43
44         dodoc AUTHORS ChangeLog README "${FILESDIR}"/iftoprc
45 }