dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-analyzer / ifstatus / ifstatus-2.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 KEYWORDS="~amd64 ~arm ~ppc ~x86"
8
9 DESCRIPTION="A simple CLI program for displaying network statistics in real time"
10 HOMEPAGE="http://ifstatus.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14
15 RDEPEND="
16         >=sys-libs/ncurses-4.2:0=
17 "
18 DEPEND="
19         ${RDEPEND}
20         virtual/pkgconfig
21 "
22 PATCHES=(
23         "${FILESDIR}"/${PN}-2.0.0-tinfo.patch
24 )
25 S="${WORKDIR}/${PN}-v${PV}"
26
27 src_compile() {
28         tc-export CXX PKG_CONFIG
29         emake GCC=$(tc-getCXX) ${PN}
30 }
31
32 src_install() {
33         dobin ifstatus
34         dodoc AUTHORS README
35 }
36
37 pkg_postinst() {
38         elog    "You may want to configure ~/.ifstatus/ifstatus.cfg"
39         elog    "before running ifstatus. For example, you may add"
40         elog    "Interfaces = eth0 there. Read the README file for"
41         elog    "more information."
42 }