dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / net-analyzer / gvm-tools / gvm-tools-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7 DISTUTILS_USE_SETUPTOOLS=rdepend
8 inherit distutils-r1
9
10 DESCRIPTION="Remote control for Greenbone Vulnerability Manager, previously named openvas-cli"
11 HOMEPAGE="https://www.greenbone.net/en/"
12 SRC_URI="https://github.com/greenbone/gvm-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-3"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/defusedxml[${PYTHON_USEDEP}]
21         dev-python/lxml[${PYTHON_USEDEP}]
22         dev-python/paramiko[${PYTHON_USEDEP}]
23         dev-python/pythondialog:0[${PYTHON_USEDEP}]
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         !net-analyzer/openvas-cli
26         !net-analyzer/openvas-tools"
27
28 DEPEND="
29         ${RDEPEND}"
30
31 src_prepare() {
32         distutils-r1_python_prepare_all
33         # Exlude tests & correct FHS/Gentoo policy paths
34         sed -i "s/packages=find_packages(),.*/packages=find_packages(exclude=['tests*', 'docs']),/" "$S"/setup.py || die
35         sed -i -e "s*''*'/usr/share/doc/${P}'*g" "$S"/setup.py || die
36 }