net-analyzer/sslscan: add 1.11.13
[gentoo.git] / net-analyzer / fping / fping-4.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A utility to ping multiple hosts at once"
7 HOMEPAGE="http://fping.org/"
8 SRC_URI="http://fping.org/dist/${P}.tar.gz"
9
10 LICENSE="fping"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
13 IUSE="ipv6 suid"
14
15 PATCHES=(
16         "${FILESDIR}"/${PN}-4.1-ipv6.patch
17 )
18
19 src_configure() {
20         econf $(use_enable ipv6)
21 }
22
23 src_install() {
24         default
25
26         if use suid ; then
27                 fperms u+s /usr/sbin/fping
28         fi
29 }