net-analyzer/zabbix: removed obsolete 4.0.18 and 4.4.6
[gentoo.git] / net-analyzer / flowgrind / flowgrind-0.8.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Network performance measurement tool"
7 HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
8 SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="debug doc gsl pcap"
14
15 RDEPEND="
16         sys-apps/util-linux
17         dev-libs/xmlrpc-c[abyss,curl]
18         gsl? ( sci-libs/gsl )
19         pcap? ( net-libs/libpcap )
20 "
21 DEPEND="
22         ${RDEPEND}
23         doc? ( app-doc/doxygen )
24 "
25
26 src_configure() {
27         econf \
28                 $(use_enable debug) \
29                 $(use_with doc doxygen) \
30                 $(use_with gsl) \
31                 $(use_with pcap)
32 }
33
34 src_compile() {
35         default
36
37         use doc && emake html
38 }
39
40 src_install() {
41         default
42
43         use doc && dodoc -r doc/html
44 }