net-analyzer/openbsd-netcat: version bump.
[gentoo.git] / net-analyzer / cbm / cbm-0.1-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils
7
8 DESCRIPTION="Display the current traffic on all network devices"
9 HOMEPAGE="http://www.isotton.com/software/unix/cbm/"
10 SRC_URI="http://www.isotton.com/software/unix/${PN}/download/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="
17         sys-libs/ncurses
18 "
19 DEPEND="
20         ${RDEPEND}
21         app-text/xmlto
22         app-text/docbook-xml-dtd:4.4
23         virtual/pkgconfig
24 "
25
26 src_prepare() {
27         epatch \
28                 "${FILESDIR}"/${P}-gcc-4.3.patch \
29                 "${FILESDIR}"/${P}-gcc-4.7.patch \
30                 "${FILESDIR}"/${P}-tinfo.patch \
31                 "${FILESDIR}"/${P}-headers-status-line.patch
32         eautoreconf
33 }