dev-ros/filters: Backport upstream fix to build without rostest when tests are not...
[gentoo.git] / net-analyzer / calamaris / calamaris-2.99.4.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="Calamaris parses the logfiles of a wide variety of Web proxy servers and generates reports"
8 HOMEPAGE="http://cord.de/calamaris-home-page"
9 SRC_URI="http://cord.de/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~ppc ~x86"
14
15 RDEPEND="
16         dev-lang/perl
17         dev-perl/GDGraph
18 "
19
20 src_prepare() {
21         sed -i \
22                 -e "s:\(use lib\).*$:\1 '/usr/share/';:" \
23                 calamaris || die
24 }
25
26 src_install() {
27         dobin calamaris calamaris-cache-convert
28
29         insinto /usr/share/${PN}
30         doins *.pm
31
32         doman calamaris.1
33
34         dodoc BUGS CHANGES EXAMPLES EXAMPLES.v3 README TODO calamaris.conf
35 }