app-emulation/simh: drop old
[gentoo.git] / net-analyzer / cacti-spine / cacti-spine-1.2.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 MY_P=${PN}-${PV/_p/-}
8
9 DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
10 HOMEPAGE="https://cacti.net/spine_info.php"
11 SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 sparc x86"
16 IUSE="libressl"
17
18 CDEPEND="
19         !libressl? ( dev-libs/openssl:0= )
20         libressl? ( dev-libs/libressl:0= )
21         net-analyzer/net-snmp:=
22         dev-db/mysql-connector-c:0=
23 "
24 DEPEND="
25         ${CDEPEND}
26         sys-apps/help2man
27 "
28 RDEPEND="
29         ${CDEPEND}
30         >net-analyzer/cacti-0.8.8
31 "
32 PATCHES=(
33         "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
34 )
35
36 src_prepare() {
37         default
38
39         eautoreconf
40 }
41
42 src_install() {
43         dosbin spine
44
45         insinto /etc/
46         insopts -m0640 -o root
47         newins spine.conf{.dist,}
48
49         doman spine.1
50         dodoc CHANGELOG
51 }