dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-analyzer / arpoison / arpoison-0.6-r2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A utility to poison ARP caches"
9 HOMEPAGE="http://arpoison.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ppc x86"
15
16 RDEPEND="net-libs/libnet:1.1"
17 DEPEND="${RDEPEND}"
18
19 S="${WORKDIR}/${PN}"
20
21 src_prepare() {
22         # respect CFLAGS, LDFLAGS and compiler, bug #337896
23         # fix for crosscompilation, bug #375655
24         sed -i Makefile \
25                 -e 's|gcc \(-Wall\)|$(CC) \1 $(CFLAGS) $(LDFLAGS)|' \
26                 -e "s|libnet-config|${ROOT}usr/bin/libnet-config|g" \
27                 || die
28 }
29
30 src_compile() {
31         emake CC="$(tc-getCC)"
32 }
33
34 src_install() {
35         dosbin arpoison
36         doman arpoison.8
37         dodoc README TODO
38 }