dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / media-video / shrip / shrip-0.6.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Command line tool for ripping DVDs and encoding to AVI/OGM/MKV/MP4"
7 HOMEPAGE="http://ogmrip.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/ogmrip/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="nls"
14
15 RDEPEND=">=dev-libs/glib-2.14:2
16         >=media-video/ogmrip-0.13.4"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig
19         nls? ( dev-util/intltool
20                 sys-devel/gettext )"
21
22 src_prepare() {
23         default
24         sed -i \
25                 -e '/CFLAGS/s:-Werror::' \
26                 configure || die
27 }
28
29 src_configure() {
30         econf $(use_enable nls)
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35         dodoc AUTHORS ChangeLog README TODO
36
37         insinto /etc
38         doins shrip.conf
39 }