Use https by default
[gentoo.git] / media-video / mplay-sh / mplay-sh-0.5.3-r1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit eutils
6
7 MY_P="mplay-${PV}"
8
9 DESCRIPTION="mplayer wrapper script as backend for vdr-mplayer"
10 HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=62306"
11 SRC_URI="mirror://gentoo/${MY_P}.tgz
12         https://dev.gentoo.org/~zzam/distfiles/${MY_P}.tgz"
13
14 KEYWORDS="x86 ~amd64"
15 SLOT="0"
16 LICENSE="GPL-2"
17 IUSE=""
18
19 DEPEND="media-tv/gentoo-vdr-scripts"
20 RDEPEND=">=media-video/mplayer-0.90_rc4"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         sed -i mplay.sh \
28                 -e 's#$CONFDIR/silence.wav#/usr/share/vdr/mplay-sh/silence.wav#'
29         sed -i conf.examples/mplayrc \
30                 -e 's#^MPLAY_PLAY.*#MPLAY_PLAY="/var/vdr/tmp/mplay.play"#'
31 }
32
33 src_install() {
34         exeinto /usr/share/vdr/mplayer/bin
35         doexe mplay.sh
36
37         insinto /etc/vdr/plugins/mplay
38         doins conf.examples/*.conf conf.examples/mplayrc
39
40         insinto /usr/share/vdr/mplay-sh
41         doins conf.examples/silence.wav
42
43         dodoc README* HISTORY
44         keepdir /var/vdr/tmp
45         chown vdr:vdr -R "${D}/var/vdr"
46 }