media-video/pitivi: support py3.7, ensure working gst-transcoder
[gentoo.git] / media-video / ffcast / ffcast-2.4.8.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Record screencasts using ffmpeg"
9 HOMEPAGE="https://github.com/lolilolicon/ffcast"
10 SRC_URI="https://github.com/lolilolicon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="x11-apps/xdpyinfo
18                 x11-apps/xprop
19                 x11-apps/xwininfo
20                 x11-apps/xrectsel
21                 media-video/ffmpeg
22                 >=app-shells/bash-4.3"
23 DEPEND=""
24
25 S="${WORKDIR}/FFcast-${PV}"
26
27 src_prepare() {
28         rmdir src/xrectsel
29         eapply_user
30         eautoreconf
31 }