media-video/dirac: drop dead dependency
[gentoo.git] / media-video / dirac / dirac-1.0.2-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils multilib-minimal
6
7 DESCRIPTION="Open Source video codec"
8 HOMEPAGE="http://dirac.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="MPL-1.1"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
14 IUSE="debug doc cpu_flags_x86_mmx static-libs"
15
16 RDEPEND=""
17 DEPEND="
18         doc? (
19                 app-doc/doxygen
20                 virtual/latex-base
21                 media-gfx/graphviz
22                 >=app-text/texlive-core-2014
23         )"
24 DOCS=( AUTHORS ChangeLog NEWS README TODO )
25
26 src_prepare() {
27         epatch "${FILESDIR}"/${PN}-0.5.2-doc.patch
28         AT_M4DIR="m4" eautoreconf
29         export VARTEXFONTS="${T}/fonts"
30 }
31
32 multilib_src_configure() {
33         ECONF_SOURCE="${S}" econf \
34                 $(use_enable static-libs static) \
35                 $(use_enable cpu_flags_x86_mmx mmx) \
36                 $(use_enable debug) \
37                 $(multilib_is_native_abi && echo $(use_enable doc))
38         if ! multilib_is_native_abi ; then
39                 sed -i -e 's/ encoder decoder util//' Makefile || die
40         fi
41 }
42
43 multilib_src_install() {
44         emake \
45                 DESTDIR="${D}" \
46                 htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
47                 latexdir="${EPREFIX}/usr/share/doc/${PF}/programmers" \
48                 algodir="${EPREFIX}/usr/share/doc/${PF}/algorithm" \
49                 faqdir="${EPREFIX}/usr/share/doc/${PF}" \
50                 install
51 }
52
53 multilib_src_install_all() {
54         prune_libtool_files --all
55         einstalldocs
56 }