media-tv/plex-media-server: Bump to 1.19.1
[gentoo.git] / media-tv / tvbrowser-bin / tvbrowser-bin-4.0.1.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit desktop
7
8 MY_PN="tvbrowser"
9 MY_P="${MY_PN}-${PV}"
10
11 DESCRIPTION="Themeable and easy to use TV Guide - written in Java"
12 HOMEPAGE="https://www.tvbrowser.org"
13 SRC_URI="mirror://sourceforge/project/tvbrowser/TV-Browser%20Releases%20%28Java%208%20and%20higher%29/${PV}/${MY_PN}_${PV}_bin.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 RDEPEND="virtual/jdk:1.8"
20
21 S="${WORKDIR}"/"${MY_P}"
22
23 src_install() {
24         # Copy files and directories
25         insinto /opt/"${P}"
26         doins -r *
27
28         # Generate launcher
29         exeinto /opt/bin
30         newexe - tvbrowser <<-_EOF_
31                 #!/bin/bash
32                 export JAVA_OPTS="\${JAVA_OPTS} -Dpropertiesfile=/opt/${P}/linux.properties"
33                 exec /bin/bash /opt/${P}/tvbrowser.sh "\$@"
34         _EOF_
35
36         # Generate desktop entry
37         make_desktop_entry tvbrowser "TV-Browser" \
38                 /opt/"${P}"/imgs/tvbrowser128.png \
39                 "AudioVideo;TV;Video"
40 }