media-tv/mythtv: ebuild enhancements
[gentoo.git] / media-tv / ivtvplayer / ivtvplayer-0.1.3-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Simple IVTV command line TV and radio player with support of LIRC"
7 HOMEPAGE="https://sourceforge.net/projects/ivtvplayer/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
9
10 SLOT="0"
11 LICENSE="GPL-2"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="gtk"
14
15 RDEPEND="media-tv/v4l-utils
16          || ( media-video/mplayer[v4l]
17                 media-video/mplayer[dvb] )
18          media-sound/alsa-utils
19          dev-perl/XML-Simple
20          gtk? ( dev-perl/Gtk2 )
21          dev-perl/X-Osd
22          >=dev-perl/Lirc-Client-1.50"
23 DEPEND="${RDEPEND}"
24
25 src_install() {
26         dobin bin/itv
27         dobin bin/iradio
28         use gtk && dobin bin/ictl
29         dodoc doc/README doc/CHANGES
30         dodoc -r conf
31 }
32
33 pkg_postinst() {
34         einfo ""
35         einfo "Example of itv, iradio and its LIRC configuration file is located in"
36         einfo "directory /usr/share/doc/${PF}/."
37         einfo ""
38 }