media-sound/qjackctl: removed obsolete 0.6.1
[gentoo.git] / media-sound / yoshimi / yoshimi-1.7.0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake xdg flag-o-matic
7
8 DESCRIPTION="Software synthesizer based on ZynAddSubFX"
9 HOMEPAGE="https://yoshimi.github.io/"
10 SRC_URI="https://github.com/${PN^}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="+lv2"
16
17 BDEPEND="virtual/pkgconfig"
18 DEPEND="
19         >=dev-libs/mxml-2.5
20         media-libs/alsa-lib
21         media-libs/fontconfig
22         media-libs/libsndfile
23         sci-libs/fftw:3.0=
24         sys-libs/ncurses:0=
25         sys-libs/readline:0=
26         sys-libs/zlib
27         virtual/jack
28         x11-libs/cairo[X]
29         x11-libs/fltk:1[opengl]
30         lv2? ( media-libs/lv2 )
31 "
32 RDEPEND="${DEPEND}"
33
34 CMAKE_USE_DIR="${WORKDIR}/${P}/src"
35
36 DOCS=( Changelog README.txt )
37
38 src_prepare() {
39         cmake_src_prepare
40         append-cxxflags -lpthread
41         append-cppflags -lpthread
42 }
43
44 src_configure() {
45         local mycmakeargs=( -DLV2Plugin=$(usex lv2) )
46         cmake_src_configure
47 }
48 src_install() {
49         cmake_src_install
50         mv "${D}"/usr/share/doc/yoshimi "${D}"/usr/share/doc/${P}
51 }