dev-python/natsort: Support newer python
[gentoo.git] / media-sound / xnoise / xnoise-0.2.21.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit fdo-mime gnome2-utils
6
7 DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of
8 features"
9 HOMEPAGE="http://www.xnoise-media-player.com/"
10 SRC_URI="https://www.bitbucket.org/shuerhaaken/${PN}/downloads/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="ayatana +lastfm +lyrics"
16
17 RDEPEND="x11-libs/gtk+:3
18         >=dev-libs/glib-2.34:2
19         gnome-base/librsvg:2
20         media-libs/gstreamer:1.0
21         media-libs/gst-plugins-base:1.0
22         media-plugins/gst-plugins-meta:1.0
23         dev-db/sqlite:3
24         >=media-libs/libtaginfo-0.2.0
25         x11-libs/cairo
26         x11-libs/libX11
27         ayatana? ( dev-libs/libappindicator:3 )
28         lastfm? ( net-libs/libsoup:2.4 )
29         lyrics? ( net-libs/libsoup:2.4
30                 dev-libs/libxml2:2 )"
31 DEPEND="${RDEPEND}
32         dev-util/intltool
33         virtual/pkgconfig
34         sys-devel/gettext"
35
36 DOCS=( AUTHORS README )
37
38 src_prepare() {
39         sed -i -e "/OnlyShowIn/d" data/misc/xnoise.desktop.* || die
40 }
41
42 src_configure() {
43         econf \
44                 $(use_enable ayatana appindicator) \
45                 $(use_enable lyrics lyricwiki) \
46                 $(use_enable lastfm) \
47                 --enable-mpris \
48                 --enable-soundmenu2 \
49                 --enable-mediakeys \
50                 $(use_enable lyrics chartlyrics) \
51                 $(use_enable lyrics azlyrics) \
52                 --enable-magnatune
53 }
54
55 src_install() {
56         default
57         find "${ED}" -type f -name "*.la" -delete || die
58         rm -rf "${ED}"/usr/share/${PN}/license || die
59 }
60
61 pkg_preinst() {
62         gnome2_icon_savelist
63 }
64
65 pkg_postinst() {
66         fdo-mime_desktop_database_update
67         gnome2_icon_cache_update
68 }
69
70 pkg_postrm() {
71         fdo-mime_desktop_database_update
72         gnome2_icon_cache_update
73 }