media-sound/strawberry: Removed old
[gentoo.git] / media-sound / xnoise / xnoise-0.2.21.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg
7
8 DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of features"
9 HOMEPAGE="http://www.xnoise-media-player.com/"
10 SRC_URI="https://www.bitbucket.org/shuerhaaken/${PN}/downloads/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="appindicator +lastfm +lyrics"
16
17 RDEPEND="
18         dev-db/sqlite:3=
19         dev-libs/glib:2
20         gnome-base/librsvg:2
21         media-libs/gstreamer:1.0=
22         media-libs/gst-plugins-base:1.0=
23         media-libs/libtaginfo:=
24         media-plugins/gst-plugins-meta:1.0
25         x11-libs/cairo:=
26         x11-libs/gtk+:3
27         x11-libs/libX11
28         appindicator? ( dev-libs/libappindicator:3= )
29         lastfm? ( net-libs/libsoup:2.4= )
30         lyrics? (
31                 net-libs/libsoup:2.4=
32                 dev-libs/libxml2:2=
33         )"
34 DEPEND="${RDEPEND}"
35 BDEPEND="
36         dev-util/intltool
37         sys-devel/gettext
38         virtual/pkgconfig"
39
40 PATCHES=( "${FILESDIR}"/${PN}-0.2.21-QA-fix-desktop-file.patch )
41
42 src_configure() {
43         econf \
44                 --enable-magnatune \
45                 --enable-mediakeys \
46                 --enable-mpris \
47                 --enable-soundmenu2 \
48                 $(use_enable appindicator) \
49                 $(use_enable lastfm) \
50                 $(use_enable lyrics lyricwiki) \
51                 $(use_enable lyrics chartlyrics) \
52                 $(use_enable lyrics azlyrics)
53 }
54
55 src_install() {
56         default
57         rm -rf "${ED}"/usr/share/${PN}/license || die
58
59         # no static archives
60         find "${D}" -name '*.la' -delete || die
61 }